PHP 7 neuer Standard

15.03.2018/koma

PHP 7 neuer Standard

Mit PHP 5 gab es 2004 das letzte sogenannte Major Release der Skriptsprache. PHP wird laufend weiterentwickelt und zählt heute zu den populärsten Skritpsprachen im Internet. Seit 2015 steht nun mit PHP 7 der neuste grosse Release zur Verfügung.

Die Entwickler haben PHP 7 einer Generalüberholung unterzogen und gleichzeitig einige  ältere Funktionen entfernt. Ältere Versionen von phpwcms (< V1.9) sind mit PHP 7 nicht mehr kompatibel.

Ab Ende 2017 wird die ältere PHP Version 5 offiziell nicht mehr unterstützt. Somit werden die meisten Provider diese Version deaktivieren und nur noch PHP 7 zur Verfügung stellen. CMS System welche nicht PHP 7 kompatibel sind werden dann nicht mehr funktionieren.

 

phpwcms 1.9 - PHP 7 ready

Die neuste Version von phpwcms, Version 1.9, ist nun rechtzeitig freigegeben worden. Diese Version ist nun PHP 7 kompatibel und weisst zudem diverse Verbesserungen auf.

Ältere CMS System können mit wenig Aufwand aktualisiert werden. Module oder andere kundenspezifische Applikationen müssen jedoch individuell an PHP 7 angepasst werden.

Webseiten, welchen auf phpwcms basieren, müssen also bis Ende 2018 aktualisiert werden. Wir werden alle betroffenen Kunden rechtzeitig über das weitere Vorgehen informieren.